GameChanger is experiencing overall site slowness
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 3 months ago. May 31, 2018 - 18:51 EDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. May 31, 2018 - 18:51 EDT
Identified
We have identified the cause of longer than normal load times throughout the site and mobile API. Our engineers are working on a fix to bring speeds back to normal.
Posted 3 months ago. May 31, 2018 - 18:32 EDT
This incident affected: GC.com, Baseball and Softball App API, and Team Manager App API.