Email alerts may be delayed
Incident Report for GameChanger
Resolved
Email alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted about 1 month ago. Apr 19, 2018 - 22:35 EDT
Monitoring
Email alerts are now being sent. You may continue to experience slight delays due to the large backlog.
Posted about 1 month ago. Apr 19, 2018 - 22:27 EDT
Update
We are still investigating this issue with our email service provider. We will provide an update once email alerts are working once again.
Posted about 1 month ago. Apr 19, 2018 - 21:37 EDT
Investigating
Email alerts are delayed. Our engineers are investigating the cause of the issue.
Posted about 1 month ago. Apr 19, 2018 - 21:08 EDT