Email game alerts may be delayed
Incident Report for GameChanger
Resolved
Email game alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted 3 months ago. May 23, 2019 - 19:06 EDT
Identified
Email game alerts are delayed. Our engineers are investigating the cause of the issue.
Posted 3 months ago. May 23, 2019 - 18:41 EDT
This incident affected: SMS and Email Alerts.