Email notifications may be delayed
Incident Report for GameChanger
Resolved
We have resolved the issue, thank you for your patience. We apologize for any inconvenience this may have caused.
Have a pleasant day!
-GameChanger Team
Posted 10 months ago. May 17, 2018 - 14:54 EDT
Monitoring
We are still experiencing occasional email failures. However most of our email services are now fully functional. Thank you for your patience and understanding.
Posted 10 months ago. May 17, 2018 - 13:59 EDT
Identified
We are experiencing problems sending emails. Team announcements, schedule changes, and RSVP reminders may be delayed.
Posted 10 months ago. May 17, 2018 - 11:06 EDT