GameStream updates are not being delivered
Incident Report for GameChanger
Resolved
Our GameStream service is now fully operational. We apologize for the inconvenience and thank you again for your patience
Posted 14 days ago. Oct 06, 2018 - 12:59 EDT
Identified
We have identified the issue impacting the GameStream and are working on a resolution
Posted 14 days ago. Oct 06, 2018 - 12:41 EDT
Investigating
Our engineers are investigating the issue, thank you for your patience
Posted 14 days ago. Oct 06, 2018 - 12:27 EDT
This incident affected: Live GameStream Updates.