Team Manager users may experience issues with searching for newly created teams
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 14:35 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2021 - 12:59 EDT
This incident affected: Team Manager App API.