TeamManager is experiencing overall slowness
Incident Report for GameChanger
Resolved
TeamManager performance should now be normal. Please contact support if you continue to experience issues.
Posted 3 months ago. Aug 29, 2018 - 14:12 EDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Aug 29, 2018 - 14:12 EDT
Investigating
TeamManager is experiencing slow response times throughout our site. You may be noticing longer than normal load times. Our engineers are investigating to bring speeds back to normal.
Posted 3 months ago. Aug 29, 2018 - 14:00 EDT
This incident affected: Team Manager App API.