Services are facing difficulty
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jul 11, 2020 - 18:58 EDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2020 - 16:23 EDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2020 - 16:10 EDT
Investigating
We are currently investigating this issue.
Posted Jul 11, 2020 - 15:40 EDT
This incident affected: Team Manager App API.