Stat calculation delays
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 19, 2019 - 21:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Mar 19, 2019 - 21:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted 7 months ago. Mar 19, 2019 - 21:00 EDT
Identified
We have identified the cause of stat calculation delays and our engineers are working to fix it.
Posted 7 months ago. Mar 19, 2019 - 20:26 EDT
This incident affected: Live GameStream Updates and Stat Calculation.