Stat calculation delays
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted 11 months ago. May 31, 2017 - 21:13 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 31, 2017 - 20:37 EDT
Investigating
Some game and player stats are calculating slowly. Notifications may also be delayed. Our engineers are investigating the cause of the issue.
Posted 11 months ago. May 31, 2017 - 20:21 EDT