Issues with payments processing
Incident Report for GameChanger
Resolved
Payment processing and access to billing info should be back to normal. If you continue to experience issues please contact support.
Posted about 1 year ago. Mar 16, 2017 - 10:15 EDT
Identified
We are currently experiencing issues processing payments and updating billing info. You may experience delayed payment processing or failure of your charge to process. Our engineers are working to fix the issue. If you experience continued payment failures please contact customer support.
Posted about 1 year ago. Mar 16, 2017 - 09:28 EDT