Payments made with Visa are not processing
Incident Report for GameChanger
Resolved
The issue causing payments with Visa credit cards to be denied has been solved. Payments should be processed correctly.
Posted over 1 year ago. Mar 21, 2017 - 09:29 EDT
Identified
We are currently experiencing issues processing payments made with a Visa credit card. You may experience failure of your charge to process or an inaccurate "declined" notification if you pay with Visa. Our engineers are working to fix the issue.
Posted over 1 year ago. Mar 21, 2017 - 08:16 EDT