Live Stream & Stat calculation delays
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 20:58 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 13, 2021 - 20:48 EDT
Investigating
Some game and player stats are calculating slowly. Our engineers are investigating the cause of the issue.
Posted Jul 13, 2021 - 20:29 EDT
This incident affected: Live GameStream Updates and Stat Calculation.