Team Search in Team Manager is experiencing degraded performance.
Incident Report for GameChanger
Resolved
This incident has been resolved.
Posted Jul 10, 2021 - 19:43 EDT
Investigating
We are currently investigating this issue.
Posted Jul 10, 2021 - 14:43 EDT
This incident affected: Team Manager App API.