Email alerts are delayed
Incident Report for GameChanger
Resolved
Email alerts are now being sent normally. Please contact support if you continue to experience issues.
Posted 4 months ago. Apr 11, 2019 - 13:51 EDT
Investigating
Email alerts are delayed. Our engineers are investigating the cause of the issue.
Posted 4 months ago. Apr 11, 2019 - 13:24 EDT
This incident affected: SMS and Email Alerts.